If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Powercurve
Page 13 of 13 FirstFirst ... 3910111213
Results 241 to 251 of 251
  1. #241
    Member Russell's Avatar
    Join Date
    Nov 2012
    Location
    Wendell, NC
    Posts
    654

    Default

    It was not the injectors. I had 5v sensor wire grounding out. The mustang did a lot of sitting on jack stands, but after buying repairing and selling a 93 Lighting I have finally got the turbo on and running.

    I need to get the closed loop boost controller set up. I am hoping to take it back to the Dyno soon, and maybe to Roxboro's TNT on Saturday.

  2. #242
    never ending project arnie93lx's Avatar
    Join Date
    Nov 2010
    Location
    Columbus, Ohio
    Posts
    1,004

    Default

    You mean the pulse (power) wire on the EFI harness for the injectors? Good find

  3. #243
    Member Russell's Avatar
    Join Date
    Nov 2012
    Location
    Wendell, NC
    Posts
    654

    Default

    Quote Originally Posted by arnie93lx View Post
    You mean the pulse (power) wire on the EFI harness for the injectors? Good find
    The problem was self inflicted as most of mine are. I was working on installing a wheel speed sensor (never finished) I was using the power tap on the Holley harness for sensor power and ground. I did not do a good job capping off the end of the unused wires. They shorted out causing the sensors that run the engine to go crazy. As I recall it messed up the signal from the MAP and TPS? Once I figured it out (review data logs and Internet) I just unhooked the power tap. That was after I pulled the upper intake and injectors to check them.

  4. #244
    Member Russell's Avatar
    Join Date
    Nov 2012
    Location
    Wendell, NC
    Posts
    654

    Default

    Didn't make it to the track Saturday, but was able to put it on the Dyno Sunday. I forget to get the graph. It made in the 330s rwhp at around 8 pounds of boost. Goals meet. Hope to enjoy it this summer and maybe turn it up this fall.

  5. #245
    Member dkcardwell's Avatar
    Join Date
    Nov 2008
    Location
    Albemarle, NC
    Posts
    1,668

    Default

    Congrats on meeting your goal Russell. Just logged into site to check on who is still around. Good luck with turning it up later.
    Daron


  6. #246
    Member Russell's Avatar
    Join Date
    Nov 2012
    Location
    Wendell, NC
    Posts
    654

    Default

    Thanks! Got the files for the Dyno runs trying to learn the software. I made a couple graphs 341 HP 408 ftlbs! I made it to the track two weeks ago. Time slips from the track, and data log from 7.90 pass. It's noticably faster. I need to work on the drivability tune some. Next project is to run the exhaust out the back.PXL_20220416_160832414_copy_1280x960.jpg

    PXL_20220420_105114173_copy_1280x960.jpg

    PXL_20220420_200212542_copy_1280x960.jpg

  7. #247
    Member Russell's Avatar
    Join Date
    Nov 2012
    Location
    Wendell, NC
    Posts
    654

    Default

    Got the down pipe connected to the cat back. It's much quieter I feel like it is less likely to attract unwanted attention. Looking forward to getting to the track and street miles!

  8. #248
    Member Russell's Avatar
    Join Date
    Nov 2012
    Location
    Wendell, NC
    Posts
    654

    Default

    Took it to Galot a couple weeks ago it's was a little slower. Doesn't build boost as quickly and made less with the same controller settings. I did have 2 ok passes a 8.06 and a 8.08. I am hoping to make it to the Gambler's race (bracket).

  9. #249
    never ending project arnie93lx's Avatar
    Join Date
    Nov 2010
    Location
    Columbus, Ohio
    Posts
    1,004

    Default

    Are you running the turbo on a factory long block? 7.90 is a great time, saw the slip above.

  10. #250
    Member Russell's Avatar
    Join Date
    Nov 2012
    Location
    Wendell, NC
    Posts
    654

    Default

    Yes, Thank you! Factory from the TB to the oil pan. 60 lb. Deka injectors. Shorty headers. DIY turbo kit. Unbranded eBay T78 or 78/75. It has a Holley EFI Terminator X. Tuned by me and transfer learn to base! Cranking and idle still need work. But its fun to tool around in, and makes cool turbo sounds.

    I feel like it should be faster. I am tempted to fill it up with E85 turn up the boost and try to get it in the low 7's

    I think my clutch is on borrowed time and more than likely the T5 is too. I have a nice spare (almost to nice to break) I also have a V6 T5 that I want to shim up and put a cluster support and maybe billet keys in. Once I get that done I might turn it up some. I really don't want to have to pull the engine out anytime soon.

  11. #251
    Member Russell's Avatar
    Join Date
    Nov 2012
    Location
    Wendell, NC
    Posts
    654

    Default

    I removed the front dump and make a A-pipe out of and only factory H-pipe and put the flow masters cat-back on. I think it's killing some HP but it still fun.

    Last Friday was the Gambler's race (low buy in bracket race) at Roxboro. I added a tiny bit of boost to the target table at the top. Truck was not available so I decided to put the 275/50/15 MT Drag Radials on it and drive it to the track. I was late leaving as always and testing had already started when I got there. I popped the hood to let it cool for a second and let some air out of the tires.

    First pass left pretty good. But felt like it was spinning and/or down on power on the top end.

    Pulled in the pit, let some more air out of the tires and made another hit.

    Second pass missed second gear and still down on power. I dug for the logs in all the files and couldn't find them. I sinked the clocks and made a third pass.

    Third pass felt good in first then low power again out the back. Time slip showed a 8.380 which backs up my first pass of 8.384 and good bracket racer would have left it alone and dialed in. I go and look for the log and it showed hitting boost cut and it reverted to waste gate at the top of first. I pulled the extra boost I had put in earlier and bumped the boost cut up some.

    Now instead of only having to decide if I want to hold any numbers I get to guess what it will run. Put 8.15 on the window. And proceed to break out on a run where I was 5+ seconds ahead of the other guy. I did try to dump some speed at the end but I didn't back off soon enough.

    Made a 5th test and tune pass ran 8.01. got back in line to make another and someone oiled the track.

    Great night at the track. If I can not rush and skip steps, and learn how to cut a light, and keep the loose nut behind the wheel from being a bone head. I might have and ok bracket car....PXL_20220827_042512220_copy_1280x960.jpgfor a stick shift turbo

Page 13 of 13 FirstFirst ... 3910111213

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •